<!DOCTYPE html>
<!--[if lt IE 7]><html
class="no-js lt-ie9 lt-ie8 lt-ie7" lang=en-US
prefix="og: https://ogp.me/ns#" > <![endif]-->
<!--[if IE 7]><html
class="no-js lt-ie9 lt-ie8" lang=en-US
prefix="og: https://ogp.me/ns#" > <![endif]-->
<!--[if IE 8]><html
class="no-js lt-ie9" lang=en-US
prefix="og: https://ogp.me/ns#" > <![endif]-->
<!--[if gt IE 8]><!--><html
class=no-js lang=en-US
prefix="og: https://ogp.me/ns#" > <!--<![endif]--><head><style media=all>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</style><title>Hot new emerging rapper &quot;T Black&quot; from Miami talks about his latest mixtape &quot;Not Afraid to Die Alone&quot; and newest singles. | 24HourHipHop</title><meta
charset=UTF-8><meta
name=google-site-verification content=duRmqPcQMQ6Ji9RQFbjqN8wrSWo1SctDwVj20ARGqyg><link
href=//www.google-analytics.com rel=dns-prefetch><meta
http-equiv=X-UA-Compatible content="IE=edge"><meta
name=viewport content="width=device-width,initial-scale=1.0,user-scalable=no"><link
rel="shortcut icon" href=https://24hourhiphop.com/wp-content/uploads/2015/11/244444blak.jpg><link
rel=pingback href=https://24hourhiphop.com/xmlrpc.php>
 <script>/* You can add more configuration options to webfontloader by previously defining the WebFontConfig with your options */
                            if ( typeof WebFontConfig === "undefined" ) {
                                WebFontConfig = new Object();
                            }
                            WebFontConfig['google'] = {families: ['Oswald:300,400,700&amp;subset=latin']};

                            (function() {
                                var wf = document.createElement( 'script' );
                                wf.src = 'https://ajax.googleapis.com/ajax/libs/webfont/1.5.3/webfont.js';
                                wf.type = 'text/javascript';
                                wf.async = 'true';
                                var s = document.getElementsByTagName( 'script' )[0];
                                s.parentNode.insertBefore( wf, s );
                            })();</script> <meta
name=description  content="INTRODUCE YOURSELF. WHO ARE YOU? WHERE ARE YOU FROM? WHAT IS YOUR BACKGROUND / NATIONALITY? My Rap name is T Black, I would mostly describe myself as a lyrical"><meta
name=keywords  content="next in line,slideshow"> <script type=application/ld+json class=aioseop-schema>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://24hourhiphop.com/#organization","url":"https://24hourhiphop.com/","name":"24HourHipHop","sameAs":["https://facebook.com/24hourhiphop","https://instagram.com/24hourhiphopviral","https://twitter.com/24hourhiphop"],"logo":{"@type":"ImageObject","@id":"https://24hourhiphop.com/#logo","url":"https://24hourhiphop.com/wp-content/uploads/2019/09/24-transparent-black-1.png","caption":""},"image":{"@id":"https://24hourhiphop.com/#logo"}},{"@type":"WebSite","@id":"https://24hourhiphop.com/#website","url":"https://24hourhiphop.com/","name":"24HourHipHop","publisher":{"@id":"https://24hourhiphop.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://24hourhiphop.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://24hourhiphop.com/features/next-in-line/hot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles/#webpage","url":"https://24hourhiphop.com/features/next-in-line/hot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles/","inLanguage":"en-US","name":"Hot new emerging rapper \"T Black\" from Miami talks about his latest mixtape \"Not Afraid to Die Alone\" and newest singles.","isPartOf":{"@id":"https://24hourhiphop.com/#website"},"breadcrumb":{"@id":"https://24hourhiphop.com/features/next-in-line/hot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles/#breadcrumblist"},"image":{"@type":"ImageObject","@id":"https://24hourhiphop.com/features/next-in-line/hot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles/#primaryimage","url":"https://24hourhiphop.com/wp-content/uploads/2020/09/IMG_2443-1.jpg","width":697,"height":1140},"primaryImageOfPage":{"@id":"https://24hourhiphop.com/features/next-in-line/hot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles/#primaryimage"},"datePublished":"2020-09-26T03:25:52+00:00","dateModified":"2020-09-26T03:30:31+00:00"},{"@type":"Article","@id":"https://24hourhiphop.com/features/next-in-line/hot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles/#article","isPartOf":{"@id":"https://24hourhiphop.com/features/next-in-line/hot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles/#webpage"},"author":{"@id":"https://24hourhiphop.com/author/vana305/#author"},"headline":"Hot new emerging rapper &#8220;T Black&#8221; from Miami talks about his latest mixtape &#8220;Not Afraid to Die Alone&#8221; and newest singles.","datePublished":"2020-09-26T03:25:52+00:00","dateModified":"2020-09-26T03:30:31+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://24hourhiphop.com/features/next-in-line/hot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles/#webpage"},"publisher":{"@id":"https://24hourhiphop.com/#organization"},"articleSection":"Next In Line, Slideshow","image":{"@type":"ImageObject","@id":"https://24hourhiphop.com/features/next-in-line/hot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles/#primaryimage","url":"https://24hourhiphop.com/wp-content/uploads/2020/09/IMG_2443-1.jpg","width":697,"height":1140}},{"@type":"Person","@id":"https://24hourhiphop.com/author/vana305/#author","name":"Vana305","sameAs":[]},{"@type":"BreadcrumbList","@id":"https://24hourhiphop.com/features/next-in-line/hot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles/#breadcrumblist","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://24hourhiphop.com/","url":"https://24hourhiphop.com/","name":"Latest Hip Hop Music Videos, Shows, News &amp; Exclusives"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://24hourhiphop.com/features/next-in-line/hot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles/","url":"https://24hourhiphop.com/features/next-in-line/hot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles/","name":"Hot new emerging rapper \"T Black\" from Miami talks about his latest mixtape \"Not Afraid to Die Alone\" and newest singles."}}]}]}</script> <link
rel=canonical href=https://24hourhiphop.com/features/next-in-line/hot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles/ ><meta
property=og:type content=article><meta
property=og:title content="Hot new emerging rapper &quot;T Black&quot; from Miami talks about his latest mixtape &quot;Not Afraid to Die Alone&quot; and newest singles. | 24HourHipHop"><meta
property=og:description content="INTRODUCE YOURSELF. WHO ARE YOU? WHERE ARE YOU FROM? WHAT IS YOUR BACKGROUND / NATIONALITY? My Rap name is T Black, I would mostly describe myself as a lyrical rapper because I use a lot of punch line"><meta
property=og:url content=https://24hourhiphop.com/features/next-in-line/hot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles/ ><meta
property=og:site_name content=24HourHipHop><meta
property=og:image content=https://24hourhiphop.com/wp-content/uploads/2020/09/IMG_2443-1-626x1024.jpg><meta
property=article:published_time content=2020-09-26T03:25:52Z><meta
property=article:modified_time content=2020-09-26T03:30:31Z><meta
property=og:image:secure_url content=https://24hourhiphop.com/wp-content/uploads/2020/09/IMG_2443-1-626x1024.jpg><meta
name=twitter:card content=summary_large_image><meta
name=twitter:site content=@24HourHipHop><meta
name=twitter:domain content=24HourHipHop><meta
name=twitter:title content="Hot new emerging rapper &quot;T Black&quot; from Miami talks about his"><meta
name=twitter:description content="INTRODUCE YOURSELF. WHO ARE YOU? WHERE ARE YOU FROM? WHAT IS YOUR BACKGROUND / NATIONALITY? My Rap name is T Black, I would mostly describe myself as a lyrical rapper because I use a lot of punch line"><meta
name=twitter:image content=https://24hourhiphop.com/wp-content/uploads/2020/09/IMG_2443-1-626x1024.jpg><link
rel=dns-prefetch href=//s0.wp.com><link
rel=alternate type=application/rss+xml title="24HourHipHop &raquo; Feed" href=https://24hourhiphop.com/feed/ ><link
rel=alternate type=application/rss+xml title="24HourHipHop &raquo; Comments Feed" href=https://24hourhiphop.com/comments/feed/ ><link
rel=alternate type=application/rss+xml title="24HourHipHop &raquo; Hot new emerging rapper &#8220;T Black&#8221; from Miami talks about his latest mixtape &#8220;Not Afraid to Die Alone&#8221; and newest singles. Comments Feed" href=https://24hourhiphop.com/features/next-in-line/hot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles/feed/ > <script src="https://24hourhiphop.com/wp-content/cache/minify/df983.js"></script>
  <script>var related_posts_js_options = {"post_heading":"h4"};</script> <script src="https://24hourhiphop.com/wp-content/cache/minify/8efe6.js"></script>
 <script type=application/json id=wpp-json>{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/24hourhiphop.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":118505,"token":"8f8f39e99b","lang":0,"debug":0}</script> <script src="https://24hourhiphop.com/wp-content/cache/minify/56d32.js"></script>
 <script>var instant_search = {"blog_url":"https:\/\/24hourhiphop.com","ajax_url":"https:\/\/24hourhiphop.com\/wp-admin\/admin-ajax.php","placeholder":"Search"};</script> <script src="https://24hourhiphop.com/wp-content/cache/minify/8dfef.js"></script>
 <link
rel=https://api.w.org/ href=https://24hourhiphop.com/wp-json/ ><link
rel=EditURI type=application/rsd+xml title=RSD href=https://24hourhiphop.com/xmlrpc.php?rsd><link
rel=wlwmanifest type=application/wlwmanifest+xml href=https://24hourhiphop.com/wp-includes/wlwmanifest.xml><link
rel=prev title='Poindexter &#8211; Jeopardy (Official Music Video)' href=https://24hourhiphop.com/hip-hop-videos/shows/elevator/music-videos-elevator/poindexter-jeopardy-official-music-video/ ><link
rel=next title='Treach: If 2Pac&#8217;s Alive, I&#8217;m Not Telling' href=https://24hourhiphop.com/hip-hop-videos/shows/vlad-tv/treach-if-2pacs-alive-im-not-telling/ ><meta
name=generator content="WordPress 5.1.1"><link
rel=shortlink href=https://wp.me/p5GSWv-uPn><link
rel=alternate type=application/json+oembed href="https://24hourhiphop.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2F24hourhiphop.com%2Ffeatures%2Fnext-in-line%2Fhot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles%2F"><link
rel=alternate type=text/xml+oembed href="https://24hourhiphop.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2F24hourhiphop.com%2Ffeatures%2Fnext-in-line%2Fhot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles%2F&#038;format=xml"><style media=screen>.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}</style><link
rel=dns-prefetch href=//v0.wordpress.com><link
rel=dns-prefetch href=//c0.wp.com><style>img#wpstats{display:none}</style><meta
name=onesignal content=wordpress-plugin> <script>window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://24hourhiphop.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '45ba4d98-f764-4b92-8878-d38121474d13';
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://24hourhiphop.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['showCredit'] = true;
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }</script>  <script type=application/ld+json class=saswp-schema-markup-output>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</script> <style id=custom-background-css>body{
			background:url('https://24hourhiphop.com/wp-content/uploads/2019/09/24hhh-tile.jpg');
		}</style><style id=vw-custom-font></style><style>::selection { color: white; background-color: #9b0000; }
		
		h1 { line-height: 1.1; }
		h2 { line-height: 1.2; }
		h3, h4, h5, h6 { line-height: 1.4; }

		.header-font,
		woocommerce div.product .woocommerce-tabs ul.tabs li, .woocommerce-page div.product .woocommerce-tabs ul.tabs li, .woocommerce #content div.product .woocommerce-tabs ul.tabs li, .woocommerce-page #content div.product .woocommerce-tabs ul.tabs li
		{ font-family: Oswald; font-weight: 700; }
		.header-font-color { color: #000000; }

		.wp-caption p.wp-caption-text {
			color: #000000;
			border-bottom-color: #000000;
		}
		
		.body-font { font-family: ; font-weight: 400; }

		/* Only header font, No font-weight */
		.mobile-nav,
		.top-nav,
		.comment .author > span, .pingback .author > span, 
		.label, .tagcloud a,
		.woocommerce .product_meta .post-tags a,
		.bbp-topic-tags a,
		.woocommerce div.product span.price, .woocommerce-page div.product span.price, .woocommerce #content div.product span.price, .woocommerce-page #content div.product span.price, .woocommerce div.product p.price, .woocommerce-page div.product p.price, .woocommerce #content div.product p.price, .woocommerce-page #content div.product p.price,
		.main-nav .menu-link { font-family: Oswald; }

		/* Primary Color */
		.primary-bg,
		.label, .tagcloud a,
		.woocommerce nav.woocommerce-pagination ul li span.current, .woocommerce-page nav.woocommerce-pagination ul li span.current, .woocommerce #content nav.woocommerce-pagination ul li span.current, .woocommerce-page #content nav.woocommerce-pagination ul li span.current, .woocommerce nav.woocommerce-pagination ul li a:hover, .woocommerce-page nav.woocommerce-pagination ul li a:hover, .woocommerce #content nav.woocommerce-pagination ul li a:hover, .woocommerce-page #content nav.woocommerce-pagination ul li a:hover, .woocommerce nav.woocommerce-pagination ul li a:focus, .woocommerce-page nav.woocommerce-pagination ul li a:focus, .woocommerce #content nav.woocommerce-pagination ul li a:focus, .woocommerce-page #content nav.woocommerce-pagination ul li a:focus,
		#pagination > span {
			background-color: #9b0000;
		}
		a, .social-share a:hover, .site-social-icons a:hover,
		.bbp-topic-header a:hover,
		.bbp-forum-header a:hover,
		.bbp-reply-header a:hover { color: #9b0000; }
		.button-primary { color: #9b0000; border-color: #9b0000; }
		.primary-border { border-color: #9b0000; }

		/* Top-bar Colors */
		.top-bar {
			background-color: #ffffff;
			color: #000000;
		}

		#open-mobile-nav, .top-nav  a, .top-bar-right > a {
			color: #000000;
		}

		#open-mobile-nav:hover, .top-nav  a:hover, .top-bar-right > a:hover {
			background-color: #9b0000;
			color: #ffffff;
		}

		.top-nav .menu-item:hover { background-color: #9b0000; }
		.top-nav .menu-item:hover > a { color: #ffffff; }

		/* Header Colors */
		.main-bar {
			background-color: #000000;
			color: #9b0000;
		}

		/* Main Navigation Colors */
		.main-nav-bar {
			background-color: #000000;
		}

		.main-nav-bar, .main-nav > .menu-item > a {
			color: #000000;
		}

		.main-nav .menu-item:hover > .menu-link,
		.main-nav > .current-menu-ancestor > a,
		.main-nav > .current-menu-item > a {
			background-color: #9b0000;
			color: #ffffff;
		}

		/* Widgets */
		.widget_vw_widget_social_subscription .social-subscription:hover .social-subscription-icon { background-color: #9b0000; }
		.widget_vw_widget_social_subscription .social-subscription:hover .social-subscription-count { color: #9b0000; }

		.widget_vw_widget_categories a:hover { color: #9b0000; }

		/* Footer Colors */
		#footer {
			background-color: #440000;
		}

		#footer .widget-title {
			color: #9b0000;
		}

		#footer,
		#footer .title,
		#footer .comment-author,
		#footer .social-subscription-count
		{ color: #ffffff; }

		.copyright {
			background-color: #000000;
		}
		.copyright, .copyright a {
			color: #dddddd;
		}

		/* Custom Styles */
				                    header.main-bar{ padding:0 !important; }

@media(min-width:878px){
	#innerleaderboard{  text-align:center; }
	.header-ads{ margin-top:22px !important; }
	.post-thumbnail-wrapper, .post-video-wrapper, .post-audio-wrapper{
	    margin-bottom:10px !important;
	}
	#postLeaderboard{ margin-bottom:10px; text-align:center; }
}
/*body{*/
/*    background: url(https://24hourhiphop.com/wp-content/uploads/2019/09/youngflock-background.jpg) !important;*/
/*    background-repeat: no-repeat !important;*/
/*    background-position: center top !important;*/
/*    background-color: #050505 !important;*/
/*    background-attachment: fixed !important;*/
/*}*/</style><style title=dynamic-css class=options-output>h1, h2, h3, h4, h5, h6{font-family:Oswald,Arial, Helvetica, sans-serif;text-transform:uppercase;font-weight:700;font-style:normal;color:#000000;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading h1, h2, h3, h4, h5, h6,{opacity: 0;}.ie.wf-loading h1, h2, h3, h4, h5, h6,{visibility: hidden;}body{font-weight:400;font-style:normal;color:#666666;font-size:14px;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading body,{opacity: 0;}.ie.wf-loading body,{visibility: hidden;}</style>
<!--[if lt IE 9]> <script src=//cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7/html5shiv.min.js></script> <script src=//cdnjs.cloudflare.com/ajax/libs/respond.js/1.3.0/respond.min.js></script> <![endif]--> <script LANGUAGE=JavaScript>function GetCookie(name) {
var arg=name+"=";
var alen=arg.length;
var clen=document.cookie.length;
var i=0;
while (i<clen) {
var j=i+alen;
if (document.cookie.substring(i,j)==arg)
return "here";
i=document.cookie.indexOf(" ",i)+1;
if (i==0) break;
}
return null;
}
var visit=GetCookie("COOKIE1");
if (visit==null){
var expire=new Date();
window.name = "thiswin";
newwin=open("https://rapflix.com/", "dispwin",
"width=600,height=350,scrollbars=yes,menubar=no");
expire=new Date(expire.getTime()+7776000000);
document.cookie="COOKIE1=here; expires="+expire;
}</script> </head><body
id=top class="post-template-default single single-post postid-118505 single-format-standard custom-background site-layout-boxed site-disable-post-box-effects"><nav
id=mobile-nav-wrapper role=navigation></nav><div
id=off-canvas-body-inner><div
id=top-bar class=top-bar><div
class=container><div
class=row><div
class=col-sm-12><div
class=top-bar-right>
<a
class=site-social-icon href=https://facebook.com/24hourhiphop title=Facebook target=_blank><i
class=icon-social-facebook></i></a><a
class=site-social-icon href=https://instagram.com/24hourhiphoptv title=Instagram target=_blank><i
class=icon-social-instagram></i></a><a
class=site-social-icon href=https://twitter.com/24hourhiphop title=Twitter target=_blank><i
class=icon-social-twitter></i></a><a
class=site-social-icon href=https://www.youtube.com/channel/UCfNqesUTLgiHQuiLy3vPApg title=Youtube target=_blank><i
class=icon-social-youtube></i></a>
<a
class=instant-search-icon href=#menu1><i
class=icon-entypo-search></i></a></div><a
id=open-mobile-nav href=#mobile-nav title=Search><i
class=icon-entypo-menu></i></a><nav
id=top-nav-wrapper><ul
id=menu-top-menu class="top-nav list-unstyled clearfix"><li
id=nav-menu-item-100796 class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-post_type menu-item-object-page menu-item-home"><a
href=https://24hourhiphop.com/ class="menu-link main-menu-link"><span>Home</span></a></li><li
id=nav-menu-item-101790 class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children"><a
href=https://24hourhiphop.com/hip-hop-music-videos/ class="menu-link main-menu-link"><span>Music &#038; Videos</span></a><ul
class="sub-menu menu-odd  menu-depth-1"><li
id=nav-menu-item-101786 class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a
href=https://24hourhiphop.com/category/hip-hop-music/official-music-videos/ class="menu-link sub-menu-link"><span>Official Music Videos</span></a></li><li
id=nav-menu-item-101787 class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a
href=https://24hourhiphop.com/category/hip-hop-music/new-juice/ class="menu-link sub-menu-link"><span>New Juice</span></a></li></ul></li><li
id=nav-menu-item-101791 class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category"><a
href=https://24hourhiphop.com/category/hip-hop-videos/shows/ class="menu-link main-menu-link"><span>Shows</span></a></li><li
id=nav-menu-item-73368 class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category"><a
href=https://24hourhiphop.com/category/news/ class="menu-link main-menu-link"><span>News</span></a></li><li
id=nav-menu-item-73371 class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent"><a
href=https://24hourhiphop.com/category/features/next-in-line/ class="menu-link main-menu-link"><span>Next In Line</span></a></li><li
id=nav-menu-item-73372 class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor"><a
href=https://24hourhiphop.com/category/features/ class="menu-link main-menu-link"><span>Features</span></a></li><li
id=nav-menu-item-73373 class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category"><a
href=https://24hourhiphop.com/category/features/exclusive-interviews/ class="menu-link main-menu-link"><span>Interviews</span></a></li><li
id=nav-menu-item-37343 class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-post_type menu-item-object-page"><a
href=https://24hourhiphop.com/contact/ class="menu-link main-menu-link"><span>Contact</span></a></li></ul></nav></div></div></div></div><header
class="main-bar header-layout-left-logo"><div
class=container><div
class=row><div
class="col-sm-12 text-center"><div
id=logo class>
<a
href=https://24hourhiphop.com/ >
<img
src=https://24hourhiphop.com/wp-content/uploads/2019/03/24hourhiphop-logo-new-1.png width=130 height=130 alt=24HourHipHop class=logo-retina>
<img
src=https://24hourhiphop.com/wp-content/uploads/2019/03/24hourhiphop-logo-new-1.png width=130 height=130 alt=24HourHipHop class=logo-original><h2 id="site-tagline" class="subtitle">All Hip Hop Music, Videos &amp; Latest Breaking News</h2>
</a></div><div
class="header-ads hidden-xs hidden-sm hidden-md"><div
class="g g-1"><div
class="g-single a-23"><a
class=gofollow data-track=MjMsMSwxLDYw href=https://rapflix.com><img
src=https://24hourhiphop.com/wp-content/uploads/2019/07/rapflix-728-90-ad.gif></a></div></div></div></div></div></div></header><div
class="main-nav-bar header-layout-left-logo"><div
class=container><div
class=row><div
class=col-sm-12></div></div></div></div><div
class=top-posts><div
class=container><div
class=row>
<a
href=# class=carousel-nav-prev></a>
<a
href=# class=carousel-nav-next></a><div
class=top-posts-inner><div
class="post-box-wrapper  "><article
class="post-118662 post-box post-box-headline"><h3 class="title title-small"><a
href=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-split-a-pill-official-audio/ title="Permalink to Machine Gun Kelly &#8211; split a pill (Official Audio)" rel=bookmark>Machine Gun Kelly &#8211; split a pill (Official Audio)</a></h3><div
class="post-thumbnail-wrapper vw-imgliquid">
<a
href=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-split-a-pill-official-audio/ title="Permalink to Machine Gun Kelly &#8211; split a pill (Official Audio)" rel=bookmark>
<img
width=265 height=147 src=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-457-265x147.jpg class="attachment-vw_small_2 size-vw_small_2 wp-post-image" alt srcset="https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-457-265x147.jpg 265w, https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-457-360x200.jpg 360w, https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-457-750x420.jpg 750w" sizes="(max-width: 265px) 100vw, 265px" data-attachment-id=118663 data-permalink=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-split-a-pill-official-audio/attachment/maxresdefault-457-16/ data-orig-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-457.jpg data-orig-size=1280,720 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;} data-image-title=maxresdefault-457 data-image-description data-medium-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-457-300x169.jpg data-large-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-457-1024x576.jpg>		</a></div></article></div><div
class="post-box-wrapper  "><article
class="post-118664 post-box post-box-headline"><h3 class="title title-small"><a
href=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-hangover-cure-official-audio/ title="Permalink to Machine Gun Kelly &#8211; hangover cure (Official Audio)" rel=bookmark>Machine Gun Kelly &#8211; hangover cure (Official Audio)</a></h3><div
class="post-thumbnail-wrapper vw-imgliquid">
<a
href=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-hangover-cure-official-audio/ title="Permalink to Machine Gun Kelly &#8211; hangover cure (Official Audio)" rel=bookmark>
<img
width=265 height=147 src=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-458-265x147.jpg class="attachment-vw_small_2 size-vw_small_2 wp-post-image" alt srcset="https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-458-265x147.jpg 265w, https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-458-360x200.jpg 360w, https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-458-750x420.jpg 750w" sizes="(max-width: 265px) 100vw, 265px" data-attachment-id=118665 data-permalink=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-hangover-cure-official-audio/attachment/maxresdefault-458-16/ data-orig-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-458.jpg data-orig-size=1280,720 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;} data-image-title=maxresdefault-458 data-image-description data-medium-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-458-300x169.jpg data-large-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-458-1024x576.jpg>		</a></div></article></div><div
class="post-box-wrapper  "><article
class="post-118666 post-box post-box-headline"><h3 class="title title-small"><a
href=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-bloody-valentine-acoustic-official-audio/ title="Permalink to Machine Gun Kelly &#8211; bloody valentine acoustic (Official Audio)" rel=bookmark>Machine Gun Kelly &#8211; bloody valentine acoustic (Official Audio)</a></h3><div
class="post-thumbnail-wrapper vw-imgliquid">
<a
href=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-bloody-valentine-acoustic-official-audio/ title="Permalink to Machine Gun Kelly &#8211; bloody valentine acoustic (Official Audio)" rel=bookmark>
<img
width=265 height=147 src=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-459-265x147.jpg class="attachment-vw_small_2 size-vw_small_2 wp-post-image" alt srcset="https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-459-265x147.jpg 265w, https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-459-360x200.jpg 360w, https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-459-750x420.jpg 750w" sizes="(max-width: 265px) 100vw, 265px" data-attachment-id=118667 data-permalink=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-bloody-valentine-acoustic-official-audio/attachment/maxresdefault-459-16/ data-orig-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-459.jpg data-orig-size=1280,720 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;} data-image-title=maxresdefault-459 data-image-description data-medium-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-459-300x169.jpg data-large-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-459-1024x576.jpg>		</a></div></article></div><div
class="post-box-wrapper  "><article
class="post-118668 post-box post-box-headline"><h3 class="title title-small"><a
href=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-cant-look-back-official-audio/ title="Permalink to Machine Gun Kelly &#8211; can&#8217;t look back (Official Audio)" rel=bookmark>Machine Gun Kelly &#8211; can&#8217;t look back (Official Audio)</a></h3><div
class="post-thumbnail-wrapper vw-imgliquid">
<a
href=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-cant-look-back-official-audio/ title="Permalink to Machine Gun Kelly &#8211; can&#8217;t look back (Official Audio)" rel=bookmark>
<img
width=265 height=147 src=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-460-265x147.jpg class="attachment-vw_small_2 size-vw_small_2 wp-post-image" alt srcset="https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-460-265x147.jpg 265w, https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-460-360x200.jpg 360w, https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-460-750x420.jpg 750w" sizes="(max-width: 265px) 100vw, 265px" data-attachment-id=118669 data-permalink=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-cant-look-back-official-audio/attachment/maxresdefault-460-16/ data-orig-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-460.jpg data-orig-size=1280,720 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;} data-image-title=maxresdefault-460 data-image-description data-medium-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-460-300x169.jpg data-large-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-460-1024x576.jpg>		</a></div></article></div><div
class="post-box-wrapper  "><article
class="post-118670 post-box post-box-headline"><h3 class="title title-small"><a
href=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-ft-yungblud-bert-mccracken-of-the-used-body-bag-official-audio/ title="Permalink to Machine Gun Kelly Ft. YUNGBLUD &amp; Bert McCracken of The Used &#8211; body bag (Official Audio)" rel=bookmark>Machine Gun Kelly Ft. YUNGBLUD &amp; Bert McCracken of The Used &#8211; body bag (Official Audio)</a></h3><div
class="post-thumbnail-wrapper vw-imgliquid">
<a
href=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-ft-yungblud-bert-mccracken-of-the-used-body-bag-official-audio/ title="Permalink to Machine Gun Kelly Ft. YUNGBLUD &amp; Bert McCracken of The Used &#8211; body bag (Official Audio)" rel=bookmark>
<img
width=265 height=147 src=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-461-265x147.jpg class="attachment-vw_small_2 size-vw_small_2 wp-post-image" alt srcset="https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-461-265x147.jpg 265w, https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-461-360x200.jpg 360w, https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-461-750x420.jpg 750w" sizes="(max-width: 265px) 100vw, 265px" data-attachment-id=118671 data-permalink=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-ft-yungblud-bert-mccracken-of-the-used-body-bag-official-audio/attachment/maxresdefault-461-16/ data-orig-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-461.jpg data-orig-size=1280,720 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;} data-image-title=maxresdefault-461 data-image-description data-medium-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-461-300x169.jpg data-large-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-461-1024x576.jpg>		</a></div></article></div><div
class="post-box-wrapper  "><article
class="post-118660 post-box post-box-headline"><h3 class="title title-small"><a
href=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-drunk-face-official-music-video/ title="Permalink to Machine Gun Kelly &#8211; drunk face (Official Music Video)" rel=bookmark>Machine Gun Kelly &#8211; drunk face (Official Music Video)</a></h3><div
class="post-thumbnail-wrapper vw-imgliquid">
<a
href=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-drunk-face-official-music-video/ title="Permalink to Machine Gun Kelly &#8211; drunk face (Official Music Video)" rel=bookmark>
<img
width=265 height=147 src=https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-10-265x147.jpg class="attachment-vw_small_2 size-vw_small_2 wp-post-image" alt srcset="https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-10-265x147.jpg 265w, https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-10-360x200.jpg 360w" sizes="(max-width: 265px) 100vw, 265px" data-attachment-id=118661 data-permalink=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-drunk-face-official-music-video/attachment/hqdefault-10-17/ data-orig-file=https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-10.jpg data-orig-size=480,360 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;} data-image-title=hqdefault-10 data-image-description data-medium-file=https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-10-300x225.jpg data-large-file=https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-10.jpg>		</a></div></article></div><div
class="post-box-wrapper  "><article
class="post-118653 post-box post-box-headline"><h3 class="title title-small"><a
href=https://24hourhiphop.com/features/exclusive-interviews/meet-jimmy-jay/ title="Permalink to MEET JIMMY JAY" rel=bookmark>MEET JIMMY JAY</a></h3><div
class="post-thumbnail-wrapper vw-imgliquid">
<a
href=https://24hourhiphop.com/features/exclusive-interviews/meet-jimmy-jay/ title="Permalink to MEET JIMMY JAY" rel=bookmark>
<img
width=265 height=147 src=https://24hourhiphop.com/wp-content/uploads/2020/09/61D60BEB-A72E-4EBD-9CFC-25C70B37084B-Jimmy-Jay-265x147.jpeg class="attachment-vw_small_2 size-vw_small_2 wp-post-image" alt srcset="https://24hourhiphop.com/wp-content/uploads/2020/09/61D60BEB-A72E-4EBD-9CFC-25C70B37084B-Jimmy-Jay-265x147.jpeg 265w, https://24hourhiphop.com/wp-content/uploads/2020/09/61D60BEB-A72E-4EBD-9CFC-25C70B37084B-Jimmy-Jay-360x200.jpeg 360w, https://24hourhiphop.com/wp-content/uploads/2020/09/61D60BEB-A72E-4EBD-9CFC-25C70B37084B-Jimmy-Jay-750x420.jpeg 750w" sizes="(max-width: 265px) 100vw, 265px" data-attachment-id=118657 data-permalink=https://24hourhiphop.com/features/exclusive-interviews/meet-jimmy-jay/attachment/61d60beb-a72e-4ebd-9cfc-25c70b37084b-jimmy-jay/ data-orig-file=https://24hourhiphop.com/wp-content/uploads/2020/09/61D60BEB-A72E-4EBD-9CFC-25C70B37084B-Jimmy-Jay.jpeg data-orig-size=773,1140 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;} data-image-title="61D60BEB-A72E-4EBD-9CFC-25C70B37084B &#8211; Jimmy Jay" data-image-description data-medium-file=https://24hourhiphop.com/wp-content/uploads/2020/09/61D60BEB-A72E-4EBD-9CFC-25C70B37084B-Jimmy-Jay-203x300.jpeg data-large-file=https://24hourhiphop.com/wp-content/uploads/2020/09/61D60BEB-A72E-4EBD-9CFC-25C70B37084B-Jimmy-Jay-694x1024.jpeg>		</a></div></article></div><div
class="post-box-wrapper  hidden-sm"><article
class="post-118532 post-box post-box-headline"><h3 class="title title-small"><a
href=https://24hourhiphop.com/hip-hop-music/new-juice/t-black-ride-4-me-feat-nefia-son-official-music-video/ title="Permalink to T Black &#8211; Ride 4 Me (Feat.Nefia Son) (Official Music Video)" rel=bookmark>T Black &#8211; Ride 4 Me (Feat.Nefia Son) (Official Music Video)</a></h3><div
class="post-thumbnail-wrapper vw-imgliquid">
<a
href=https://24hourhiphop.com/hip-hop-music/new-juice/t-black-ride-4-me-feat-nefia-son-official-music-video/ title="Permalink to T Black &#8211; Ride 4 Me (Feat.Nefia Son) (Official Music Video)" rel=bookmark>
<img
width=265 height=147 src=https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-9-265x147.jpg class="attachment-vw_small_2 size-vw_small_2 wp-post-image" alt srcset="https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-9-265x147.jpg 265w, https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-9-360x200.jpg 360w" sizes="(max-width: 265px) 100vw, 265px" data-attachment-id=118533 data-permalink=https://24hourhiphop.com/hip-hop-music/new-juice/t-black-ride-4-me-feat-nefia-son-official-music-video/attachment/hqdefault-9-18/ data-orig-file=https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-9.jpg data-orig-size=480,360 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;} data-image-title=hqdefault-9 data-image-description data-medium-file=https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-9-300x225.jpg data-large-file=https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-9.jpg>		</a></div></article></div></div></div></div></div><style>.top-posts{
	display:none;
		}
	.main-bar{
		display:none;
	}
	#feature-content{
		padding:20px;
		background:#272727;
	}</style><div
id=feature-content class=col-sm-12></div><div
id=page-wrapper class=container><div
class=row><div
id=page-content class="col-sm-7 col-md-8"><article
id=post-118505 class="post-118505 post type-post status-publish format-standard has-post-thumbnail hentry category-next-in-line category-slideshow"><div
class="tags clearfix">
<a
class="label " href=https://24hourhiphop.com/category/features/next-in-line/ title="View all posts in Next In Line" rel=category>Next In Line</a><a
class="label " href=https://24hourhiphop.com/category/slideshow/ title="View all posts in Slideshow" rel=category>Slideshow</a></div><h1 class="post-title title title-large entry-title">Hot new emerging rapper &#8220;T Black&#8221; from Miami talks about his latest mixtape &#8220;Not Afraid to Die Alone&#8221; and newest singles.</h1><hr
class=hr-thin-bottom><div
class=social-share>
<span
class=header-font>SHARE ON:</span><a
class=social-facebook href="http://www.facebook.com/sharer.php?u=https%3A%2F%2F24hourhiphop.com%2Ffeatures%2Fnext-in-line%2Fhot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles%2F&amp;t=Hot new emerging rapper &#8220;T Black&#8221; from Miami talks about his latest mixtape &#8220;Not Afraid to Die Alone&#8221; and newest singles." title="Share on Facebook" target=_blank><i
class=icon-social-facebook></i></a>
<a
class=social-twitter href="https://twitter.com/home?status=Hot new emerging rapper &#8220;T Black&#8221; from Miami talks about his latest mixtape &#8220;Not Afraid to Die Alone&#8221; and newest singles. https://24hourhiphop.com/features/next-in-line/hot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles/" title="Share on Twitter" target=_blank><i
class=icon-social-twitter></i></a>
<a
class=social-googleplus href="https://plus.google.com/share?url=https%3A%2F%2F24hourhiphop.com%2Ffeatures%2Fnext-in-line%2Fhot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles%2F" title="Share on Google+" target=_blank><i
class=icon-social-gplus></i></a>
<a
class=social-pinterest href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2F24hourhiphop.com%2Ffeatures%2Fnext-in-line%2Fhot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles%2F&amp;media=https://24hourhiphop.com/wp-content/uploads/2020/09/IMG_2443-1.jpg&amp;description=Hot new emerging rapper &#8220;T Black&#8221; from Miami talks about his latest mixtape &#8220;Not Afraid to Die Alone&#8221; and newest singles." title="Share on Pinterest" target=_blank><i
class=icon-social-pinterest></i></a>
<a
class=social-email href="mailto:?subject=Hot new emerging rapper &#8220;T Black&#8221; from Miami talks about his latest mixtape &#8220;Not Afraid to Die Alone&#8221; and newest singles.&amp;body=https%3A%2F%2F24hourhiphop.com%2Ffeatures%2Fnext-in-line%2Fhot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles%2F" title="Share on E-Mail" target=_blank><i
class=icon-social-email></i></a></div><div
class="post-meta header-font">
<a
class="author-name vcard author" href=https://24hourhiphop.com/author/vana305/ title="View all posts by Vana305"><span
class=fn>Vana305</span></a>
<span
class=post-meta-separator>&mdash;</span> <a
href=https://24hourhiphop.com/features/next-in-line/hot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles/ class="post-date updated" title="Permalink to Hot new emerging rapper &#8220;T Black&#8221; from Miami talks about his latest mixtape &#8220;Not Afraid to Die Alone&#8221; and newest singles." rel=bookmark>September 25, 2020</a></div><div
class=post-thumbnail-wrapper>
<a
class=swipebox href=https://24hourhiphop.com/wp-content/uploads/2020/09/IMG_2443-1.jpg title="Permalink to image of Hot new emerging rapper &#8220;T Black&#8221; from Miami talks about his latest mixtape &#8220;Not Afraid to Die Alone&#8221; and newest singles." rel=bookmark>
<img
width=1140 height=641 src=https://24hourhiphop.com/wp-content/uploads/2020/09/IMG_2443-1-1140x641.jpg class="attachment-vw_large size-vw_large wp-post-image" alt data-attachment-id=118509 data-permalink=https://24hourhiphop.com/features/next-in-line/hot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles/attachment/img_2443-2/ data-orig-file=https://24hourhiphop.com/wp-content/uploads/2020/09/IMG_2443-1.jpg data-orig-size=697,1140 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1531543671&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;} data-image-title=IMG_2443 data-image-description data-medium-file=https://24hourhiphop.com/wp-content/uploads/2020/09/IMG_2443-1-184x300.jpg data-large-file=https://24hourhiphop.com/wp-content/uploads/2020/09/IMG_2443-1-626x1024.jpg>		</a></div><div
class="post-content clearfix"><div
id=postLeaderboard><div
class="g g-6"><div
class="g-single a-27"><a
class=gofollow data-track=MjcsNiwxLDYw href=https://www.instagram.com/satellitecrispy/ target=_blank><img
src=https://24hourhiphop.com/wp-content/uploads/2020/06/Untitled-design-min.png></a></div></div></div><h2>INTRODUCE YOURSELF. WHO ARE YOU? WHERE ARE YOU FROM? WHAT IS YOUR BACKGROUND / NATIONALITY?</h2><p>My Rap name is T Black, I would mostly describe myself as a lyrical rapper because I use a lot of punch lines in my songs. I am from Miami my background is Jamaican/Bahamian</p><h2>HOW DID YOU GET YOUR ARTIST NAME?</h2><p>I got my artist name because my first name is Tyrone so that&#8217;s what the T stands for in my name and the Black was just to represent my skin color and for my people.</p><h2>WHAT MOTIVATED YOU TO GET INTO MUSIC?</h2><p>The motivation that got me into music is it saved my life and I love music this is my passion and this is what I see myself doing for the rest of my life. To be honest nothing doesn&#8217;t seem like a job everything I do is fun and I can&#8217;t wait to keep going up in the ranks and becoming more known for my music, So I can stop working at these jobs I don&#8217;t care about. <br></p><h2>WHAT MAKES YOU UNIQUE / STAND OUT AS AN ARTIST COMPARED TO THE REST?</h2><p>What makes me unique from a majority of rappers, I am a very consistent rapper I don&#8217;t mind putting in the work and I have a deep passion for music. As far as my style and my music I always want the listeners to get content from my music or learn something from my music or even about me. Most of all I am a very good punchline rapper and very lyrical I would say.</p><h2>WHAT ARE SOMETHINGS YOU WOULD LIKE TO ACHIEVE AND WHY?</h2><p>I would love to achieve getting gold and platinum records, getting a BET Award, MTV Award, Grammy, and most of all making big impact on someone&#8217;s life with my music, I just want to be a well known artist that is very known and respected for my music and content and nothing else. I&#8217;m just all about my music and nothing else, all of these things will make me super happy because I dreamed of all these accomplishments to have in the near future.</p><h2>LET OUR READERS KNOW SOME OF THE NAMES OF PEOPLE YOU HAVE WORKED WITH. PROVIDE REFERENCES AND WRITE WHAT YOU LIKED ABOUT WORKING WITH THEM</h2><p>Right now I haven&#8217;t worked with any big artist but I have worked with a lot of serious artist such as DreLaylow, my producers Ja Labissiere and Zoerab, Nefia Son who is on my latest single &#8220;Ride 4 Me&#8221;,  DreLaylow he is my brother in this music field and even out and Ja Labissiere me and him been knowing each other since middle school. Nefia Son we met at my most recent job and I notice she had a beautiful voice, So I just told her we need to do a song together.</p><h2>What are some past achievement worth mentioning?&nbsp;</h2><p>I only got one achievement since I been on my rap/music journey I won first place at the indie fest back in 2018 it was for DA Blaze FM &amp; Power 104.9 FM and DJ YOYO was hosting the event. More achievements will come I am so hungry right now to win.null</p><h2>ON A PERSONAL LEVEL, HOW WOULD YOU DESCRIBE YOURSELF IN DETAIL?</h2><p>I would describe myself as a nice calm person,  and I&#8217;m very ambitious and want to go to far in my life, I never want to be stagnant in my life.</p><h2>WHAT IS YOUR LATEST SINGLE? WHAT ARE YOU WORKING ON?</h2><p>My latest single right now is my single &#8220;Ride 4 Me&#8221; featuring Nefia Son, I&#8217;m always working to be honest with you, I&#8217;m dropping a new single with a visual every month to keep my supporters engaged with me. I&#8217;m always writing and in the studio I love being a Rapper everything is so fun. Early Next year I&#8217;m going to release my third mixtape &#8220;I am not a Rapper.. I&#8217;m a Superhero&#8221;.</p><h2>IN THIS MUSIC INDUSTRY, WHAT IS SOMETHING YOU LEARNED THE HARD WAY?</h2><p>I learned in this industry so far you got to be consistent and you got to be fully into it or else it&#8217;s not going to work and always willing to invest in yourself especially promotion because that&#8217;s what you going to get you noticed and pick up some more supporters and will eventually start getting you paid.</p><h2>HOW LONG HAVE YOU BEEN DOING MUSIC? WHAT GOT YOU INTO MUSIC?</h2><p>I been doing music ever since I was 13 years old but actually doing it like a job, I would say two years now. I got into music cause I had a rough childhood of being homeless, going to foster care, and not having everything I wanted. So music was something I ran to get some enjoyment and happiness in my life.</p><h2>IN 5 YEARS, WHERE DO YOU SEE YOURSELF IN THE MUSIC INDUSTRY AND WHY?</h2><p>I see myself as a professional rapper that&#8217;s doing sold out shows and known all across the globe. The reason I say this because I am very motivated and hungry to make it, It is my purpose and pursuit of happiness.<br></p><h2>WHO WERE SOME MUSIC INFLUENCES YOU LISTENED TO WHILE GROWING UP? WHAT DO YOU REMEMBER WHEN YOU THINK ABOUT THEM?</h2><p>Lil Wayne, young jeezy, Eminem, and Kanye West. I remember them most because of their style and how they bought a new feeling in their music and I loved how they told their stories in their music.</p><h2>TO CLOSE OUT FOR YOUR CURRENT AND FUTURE FANS, WHAT ARE SOME LAST WORDS AND SHOUT OUTS YOU WANT TO GIVE?</h2><p>I just want to say It will only get better, I love you all and more music on the way and my favorite slogan &#8220;THE GRIND DON&#8217;T STOP!!!!&#8221;<br></p>
[instagram-feed id="@tblackforever"]<div
id=jp-relatedposts class=jp-relatedposts ><h3 class="jp-relatedposts-headline"><em>Related</em></h3></div></div></article><div
class="post-related section-container clearfix"><h2 class="section-title">Related Posts</h2><div><div
style=padding:0;margin:0; class="post-box-wrapper col-sm-6 col-md-4 "><article
class="post-118653 post-box post-box-headline"><h3 class="title title-small"><a
href=https://24hourhiphop.com/features/exclusive-interviews/meet-jimmy-jay/ title="Permalink to MEET JIMMY JAY" rel=bookmark>MEET JIMMY JAY</a></h3><div
class="post-thumbnail-wrapper vw-imgliquid">
<a
href=https://24hourhiphop.com/features/exclusive-interviews/meet-jimmy-jay/ title="Permalink to MEET JIMMY JAY" rel=bookmark>
<img
width=265 height=147 src=https://24hourhiphop.com/wp-content/uploads/2020/09/61D60BEB-A72E-4EBD-9CFC-25C70B37084B-Jimmy-Jay-265x147.jpeg class="attachment-vw_small_2 size-vw_small_2 wp-post-image" alt srcset="https://24hourhiphop.com/wp-content/uploads/2020/09/61D60BEB-A72E-4EBD-9CFC-25C70B37084B-Jimmy-Jay-265x147.jpeg 265w, https://24hourhiphop.com/wp-content/uploads/2020/09/61D60BEB-A72E-4EBD-9CFC-25C70B37084B-Jimmy-Jay-360x200.jpeg 360w, https://24hourhiphop.com/wp-content/uploads/2020/09/61D60BEB-A72E-4EBD-9CFC-25C70B37084B-Jimmy-Jay-750x420.jpeg 750w" sizes="(max-width: 265px) 100vw, 265px" data-attachment-id=118657 data-permalink=https://24hourhiphop.com/features/exclusive-interviews/meet-jimmy-jay/attachment/61d60beb-a72e-4ebd-9cfc-25c70b37084b-jimmy-jay/ data-orig-file=https://24hourhiphop.com/wp-content/uploads/2020/09/61D60BEB-A72E-4EBD-9CFC-25C70B37084B-Jimmy-Jay.jpeg data-orig-size=773,1140 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;} data-image-title="61D60BEB-A72E-4EBD-9CFC-25C70B37084B &#8211; Jimmy Jay" data-image-description data-medium-file=https://24hourhiphop.com/wp-content/uploads/2020/09/61D60BEB-A72E-4EBD-9CFC-25C70B37084B-Jimmy-Jay-203x300.jpeg data-large-file=https://24hourhiphop.com/wp-content/uploads/2020/09/61D60BEB-A72E-4EBD-9CFC-25C70B37084B-Jimmy-Jay-694x1024.jpeg>		</a></div></article></div><div
style=padding:0;margin:0; class="post-box-wrapper col-sm-6 col-md-4 "><article
class="post-118082 post-box post-box-headline"><h3 class="title title-small"><a
href=https://24hourhiphop.com/features/next-in-line/next-in-line-rippa-hardaway-da-gr8/ title="Permalink to NEXT IN LINE &#8211; RIPPA HARDAWAY &amp; DA GR8" rel=bookmark>NEXT IN LINE &#8211; RIPPA HARDAWAY &amp; DA GR8</a></h3><div
class="post-thumbnail-wrapper vw-imgliquid">
<a
href=https://24hourhiphop.com/features/next-in-line/next-in-line-rippa-hardaway-da-gr8/ title="Permalink to NEXT IN LINE &#8211; RIPPA HARDAWAY &amp; DA GR8" rel=bookmark>
<img
width=265 height=147 src=https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-6-265x147.jpg class="attachment-vw_small_2 size-vw_small_2 wp-post-image" alt srcset="https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-6-265x147.jpg 265w, https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-6-360x200.jpg 360w" sizes="(max-width: 265px) 100vw, 265px" data-attachment-id=118083 data-permalink=https://24hourhiphop.com/features/next-in-line/next-in-line-rippa-hardaway-da-gr8/attachment/hqdefault-6-25/ data-orig-file=https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-6.jpg data-orig-size=480,360 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;} data-image-title=hqdefault-6 data-image-description data-medium-file=https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-6-300x225.jpg data-large-file=https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-6.jpg>		</a></div></article></div></div></div><div
id=comments class="section-container clearfix"><h3 class="section-title">No Comment</h3><div
id=respond class=comment-respond><h3 id="reply-title" class="comment-reply-title">Leave a reply <small><a
rel=nofollow id=cancel-comment-reply-link href=/features/next-in-line/hot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles/#respond style=display:none;>Cancel reply</a></small></h3><form
action=https://24hourhiphop.com/wp-comments-post.php method=post id=commentform class=comment-form><p
class=comment-notes><span
id=email-notes>Your email address will not be published.</span> Required fields are marked <span
class=required>*</span></p><div
id=respond-textarea><p><textarea id=comment name=comment aria-required=true cols=58 rows=10 tabindex=4></textarea></p></div><div
id=respond-inputs class=clearfix><p><input
name=author type=text placeholder="Name (required)" size=30 aria-required=true></p><p><input
name=email type=text placeholder="E-Mail (required)" size=30 aria-required=true></p><p
class=last><input
name=url type=text placeholder=Website size=30></p></div><p
class=comment-subscription-form><input
type=checkbox name=subscribe_comments id=subscribe_comments value=subscribe style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;"> <label
class=subscribe-label id=subscribe-label for=subscribe_comments>Notify me of follow-up comments by email.</label></p><p
class=comment-subscription-form><input
type=checkbox name=subscribe_blog id=subscribe_blog value=subscribe style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;"> <label
class=subscribe-label id=subscribe-blog-label for=subscribe_blog>Notify me of new posts by email.</label></p><p
class=form-submit><input
name=submit type=submit id=submit class=submit value="Submit comment"> <input
type=hidden name=comment_post_ID value=118505 id=comment_post_ID>
<input
type=hidden name=comment_parent id=comment_parent value=0></p><p
style="display: none;"><input
type=hidden id=akismet_comment_nonce name=akismet_comment_nonce value=e9e7d9b9b7></p><p
style="display: none;"><input
type=hidden id=ak_js name=ak_js value=183></p></form></div></div></div><aside
id=page-sidebar class="sidebar-wrapper col-sm-5 col-md-4"><div
class=sidebar-inner><div
id=vw_widget_latest_category-5 class="widget vw-sidebar-blog widget_vw_widget_latest_category"><h3 class="widget-title"><span
class=super-title>Latest</span>Music &#038; Videos</h3><div
class=post-box-list><article
class="post-118662 post-box fly-in animated-content post-box-small-thumbnail clearfix"><div
class=post-thumbnail-wrapper>
<a
href=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-split-a-pill-official-audio/ title="Machine Gun Kelly &#8211; split a pill (Official Audio) | 24HourHipHop" rel=bookmark>
<img
width=80 height=80 src=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-457-80x80.jpg class="attachment-vw_square_tiny size-vw_square_tiny wp-post-image" alt srcset="https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-457-80x80.jpg 80w, https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-457-150x150.jpg 150w, https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-457-360x360.jpg 360w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id=118663 data-permalink=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-split-a-pill-official-audio/attachment/maxresdefault-457-16/ data-orig-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-457.jpg data-orig-size=1280,720 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;} data-image-title=maxresdefault-457 data-image-description data-medium-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-457-300x169.jpg data-large-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-457-1024x576.jpg>		</a></div><h3 class="title title-small"><a
href=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-split-a-pill-official-audio/ title="Machine Gun Kelly &#8211; split a pill (Official Audio) | 24HourHipHop" rel=bookmark>Machine Gun Kelly &#8211; split a pill (Official Audio)</a></h3><div
class="post-categories clearfix"><div
class="label label-light label-small" title="Video Post"><i
class=icon-entypo-play></i></div><a
class="label label-small" href=https://24hourhiphop.com/category/hip-hop-music/official-music-videos/ title="View all posts in Official Music Videos" rel=category>Official Music Videos</a></div></article><article
class="post-118664 post-box fly-in animated-content post-box-small-thumbnail clearfix"><div
class=post-thumbnail-wrapper>
<a
href=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-hangover-cure-official-audio/ title="Machine Gun Kelly &#8211; hangover cure (Official Audio) | 24HourHipHop" rel=bookmark>
<img
width=80 height=80 src=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-458-80x80.jpg class="attachment-vw_square_tiny size-vw_square_tiny wp-post-image" alt srcset="https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-458-80x80.jpg 80w, https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-458-150x150.jpg 150w, https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-458-360x360.jpg 360w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id=118665 data-permalink=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-hangover-cure-official-audio/attachment/maxresdefault-458-16/ data-orig-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-458.jpg data-orig-size=1280,720 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;} data-image-title=maxresdefault-458 data-image-description data-medium-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-458-300x169.jpg data-large-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-458-1024x576.jpg>		</a></div><h3 class="title title-small"><a
href=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-hangover-cure-official-audio/ title="Machine Gun Kelly &#8211; hangover cure (Official Audio) | 24HourHipHop" rel=bookmark>Machine Gun Kelly &#8211; hangover cure (Official Audio)</a></h3><div
class="post-categories clearfix"><div
class="label label-light label-small" title="Video Post"><i
class=icon-entypo-play></i></div><a
class="label label-small" href=https://24hourhiphop.com/category/hip-hop-music/official-music-videos/ title="View all posts in Official Music Videos" rel=category>Official Music Videos</a></div></article><article
class="post-118666 post-box fly-in animated-content post-box-small-thumbnail clearfix"><div
class=post-thumbnail-wrapper>
<a
href=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-bloody-valentine-acoustic-official-audio/ title="Machine Gun Kelly &#8211; bloody valentine acoustic (Official Audio) | 24HourHipHop" rel=bookmark>
<img
width=80 height=80 src=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-459-80x80.jpg class="attachment-vw_square_tiny size-vw_square_tiny wp-post-image" alt srcset="https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-459-80x80.jpg 80w, https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-459-150x150.jpg 150w, https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-459-360x360.jpg 360w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id=118667 data-permalink=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-bloody-valentine-acoustic-official-audio/attachment/maxresdefault-459-16/ data-orig-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-459.jpg data-orig-size=1280,720 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;} data-image-title=maxresdefault-459 data-image-description data-medium-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-459-300x169.jpg data-large-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-459-1024x576.jpg>		</a></div><h3 class="title title-small"><a
href=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-bloody-valentine-acoustic-official-audio/ title="Machine Gun Kelly &#8211; bloody valentine acoustic (Official Audio) | 24HourHipHop" rel=bookmark>Machine Gun Kelly &#8211; bloody valentine acoustic (Official Audio)</a></h3><div
class="post-categories clearfix"><div
class="label label-light label-small" title="Video Post"><i
class=icon-entypo-play></i></div><a
class="label label-small" href=https://24hourhiphop.com/category/hip-hop-music/official-music-videos/ title="View all posts in Official Music Videos" rel=category>Official Music Videos</a></div></article><article
class="post-118668 post-box fly-in animated-content post-box-small-thumbnail clearfix"><div
class=post-thumbnail-wrapper>
<a
href=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-cant-look-back-official-audio/ title="Machine Gun Kelly &#8211; can&#8217;t look back (Official Audio) | 24HourHipHop" rel=bookmark>
<img
width=80 height=80 src=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-460-80x80.jpg class="attachment-vw_square_tiny size-vw_square_tiny wp-post-image" alt srcset="https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-460-80x80.jpg 80w, https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-460-150x150.jpg 150w, https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-460-360x360.jpg 360w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id=118669 data-permalink=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-cant-look-back-official-audio/attachment/maxresdefault-460-16/ data-orig-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-460.jpg data-orig-size=1280,720 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;} data-image-title=maxresdefault-460 data-image-description data-medium-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-460-300x169.jpg data-large-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-460-1024x576.jpg>		</a></div><h3 class="title title-small"><a
href=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-cant-look-back-official-audio/ title="Machine Gun Kelly &#8211; can&#8217;t look back (Official Audio) | 24HourHipHop" rel=bookmark>Machine Gun Kelly &#8211; can&#8217;t look back (Official Audio)</a></h3><div
class="post-categories clearfix"><div
class="label label-light label-small" title="Video Post"><i
class=icon-entypo-play></i></div><a
class="label label-small" href=https://24hourhiphop.com/category/hip-hop-music/official-music-videos/ title="View all posts in Official Music Videos" rel=category>Official Music Videos</a></div></article><article
class="post-118670 post-box fly-in animated-content post-box-small-thumbnail clearfix"><div
class=post-thumbnail-wrapper>
<a
href=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-ft-yungblud-bert-mccracken-of-the-used-body-bag-official-audio/ title="Machine Gun Kelly Ft. YUNGBLUD &amp; Bert McCracken of The Used &#8211; body bag (Official Audio) | 24HourHipHop" rel=bookmark>
<img
width=80 height=80 src=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-461-80x80.jpg class="attachment-vw_square_tiny size-vw_square_tiny wp-post-image" alt srcset="https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-461-80x80.jpg 80w, https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-461-150x150.jpg 150w, https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-461-360x360.jpg 360w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id=118671 data-permalink=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-ft-yungblud-bert-mccracken-of-the-used-body-bag-official-audio/attachment/maxresdefault-461-16/ data-orig-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-461.jpg data-orig-size=1280,720 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;} data-image-title=maxresdefault-461 data-image-description data-medium-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-461-300x169.jpg data-large-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-461-1024x576.jpg>		</a></div><h3 class="title title-small"><a
href=https://24hourhiphop.com/hip-hop-music/official-music-videos/machine-gun-kelly-ft-yungblud-bert-mccracken-of-the-used-body-bag-official-audio/ title="Machine Gun Kelly Ft. YUNGBLUD &amp; Bert McCracken of The Used &#8211; body bag (Official Audio) | 24HourHipHop" rel=bookmark>Machine Gun Kelly Ft. YUNGBLUD &amp; Bert McCracken of The Used &#8211; body bag (Official Audio)</a></h3><div
class="post-categories clearfix"><div
class="label label-light label-small" title="Video Post"><i
class=icon-entypo-play></i></div><a
class="label label-small" href=https://24hourhiphop.com/category/hip-hop-music/official-music-videos/ title="View all posts in Official Music Videos" rel=category>Official Music Videos</a></div></article></div></div><div
id=wpp-5 class="widget vw-sidebar-blog popular-posts"><h3 class="widget-title">Popular Exclusives</h3><div
class=wpp-widget-placeholder data-widget-id=wpp-5></div></div><div
id=wpp-2 class="widget vw-sidebar-blog popular-posts"><h3 class="widget-title">Popular Today</h3><div
class=wpp-widget-placeholder data-widget-id=wpp-2></div></div><div
id=vw_widget_latest_category-7 class="widget vw-sidebar-blog widget_vw_widget_latest_category"><h3 class="widget-title"><span
class=super-title>Featured</span>Next In Line</h3><div
class=post-box-list><article
class="post-118505 post-box fly-in animated-content post-box-large-thumbnail"><div
class=post-thumbnail-wrapper>
<a
href=https://24hourhiphop.com/features/next-in-line/hot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles/ title="Hot new emerging rapper &#8220;T Black&#8221; from Miami talks about his latest mixtape &#8220;Not Afraid to Die Alone&#8221; and newest singles. | 24HourHipHop" rel=bookmark>
<img
width=360 height=200 src=https://24hourhiphop.com/wp-content/uploads/2020/09/IMG_2443-1-360x200.jpg class="attachment-vw_small size-vw_small wp-post-image" alt srcset="https://24hourhiphop.com/wp-content/uploads/2020/09/IMG_2443-1-360x200.jpg 360w, https://24hourhiphop.com/wp-content/uploads/2020/09/IMG_2443-1-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" data-attachment-id=118509 data-permalink=https://24hourhiphop.com/features/next-in-line/hot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles/attachment/img_2443-2/ data-orig-file=https://24hourhiphop.com/wp-content/uploads/2020/09/IMG_2443-1.jpg data-orig-size=697,1140 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1531543671&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;} data-image-title=IMG_2443 data-image-description data-medium-file=https://24hourhiphop.com/wp-content/uploads/2020/09/IMG_2443-1-184x300.jpg data-large-file=https://24hourhiphop.com/wp-content/uploads/2020/09/IMG_2443-1-626x1024.jpg>		</a></div><div
class=post-box-inner><div
class="post-categories clearfix">
<a
class="label label-small" href=https://24hourhiphop.com/category/features/next-in-line/ title="View all posts in Next In Line" rel=category>Next In Line</a><a
class="label label-small" href=https://24hourhiphop.com/category/slideshow/ title="View all posts in Slideshow" rel=category>Slideshow</a></div><h3 class="title"><a
href=https://24hourhiphop.com/features/next-in-line/hot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles/ title="Hot new emerging rapper &#8220;T Black&#8221; from Miami talks about his latest mixtape &#8220;Not Afraid to Die Alone&#8221; and newest singles. | 24HourHipHop" rel=bookmark>Hot new emerging rapper &#8220;T Black&#8221; from Miami talks about his latest mixtape &#8220;Not Afraid to Die Alone&#8221; and newest singles.</a></h3><div
class="post-meta header-font"></div><div
class="post-excerpt "><p>INTRODUCE YOURSELF. WHO ARE YOU? WHERE ARE YOU FROM? WHAT IS YOUR BACKGROUND / NATIONALITY? My Rap name is T Black, I would mostly describe myself as a lyrical rapper because I use a lot &#8230;</p></div><div
class="post-box-footer clearfix">
<a
class=read-more href=https://24hourhiphop.com/features/next-in-line/hot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles/ title="Hot new emerging rapper &#8220;T Black&#8221; from Miami talks about his latest mixtape &#8220;Not Afraid to Die Alone&#8221; and newest singles. | 24HourHipHop" rel=bookmark>
Read more <i
class=icon-entypo-right-open></i>
</a>
<a
class=comment-count href=https://24hourhiphop.com/features/next-in-line/hot-new-emerging-rapper-black-from-miami-talks-about-his-latest-mixtape-not-afraid-to-die-alone-and-newest-singles/#comments title="Hot new emerging rapper &#8220;T Black&#8221; from Miami talks about his latest mixtape &#8220;Not Afraid to Die Alone&#8221; and newest singles." rel=bookmark>
<i
class=icon-entypo-comment></i> 0 Comments	</a></div></div></article></div></div><div
id=vw_widget_latest_category-8 class="widget vw-sidebar-blog widget_vw_widget_latest_category"><h3 class="widget-title"><span
class=super-title>Featured</span>New Juice</h3><div
class=post-box-list><article
class="post-118532 post-box fly-in animated-content post-box-large-thumbnail"><div
class=post-thumbnail-wrapper>
<a
href=https://24hourhiphop.com/hip-hop-music/new-juice/t-black-ride-4-me-feat-nefia-son-official-music-video/ title="T Black &#8211; Ride 4 Me (Feat.Nefia Son) (Official Music Video) | 24HourHipHop" rel=bookmark>
<img
width=360 height=200 src=https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-9-360x200.jpg class="attachment-vw_small size-vw_small wp-post-image" alt srcset="https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-9-360x200.jpg 360w, https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-9-265x147.jpg 265w" sizes="(max-width: 360px) 100vw, 360px" data-attachment-id=118533 data-permalink=https://24hourhiphop.com/hip-hop-music/new-juice/t-black-ride-4-me-feat-nefia-son-official-music-video/attachment/hqdefault-9-18/ data-orig-file=https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-9.jpg data-orig-size=480,360 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;} data-image-title=hqdefault-9 data-image-description data-medium-file=https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-9-300x225.jpg data-large-file=https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-9.jpg>		</a></div><div
class=post-box-inner><div
class="post-categories clearfix"><div
class="label label-light label-small" title="Video Post"><i
class=icon-entypo-play></i></div><a
class="label label-small" href=https://24hourhiphop.com/category/hip-hop-music/new-juice/ title="View all posts in New Juice" rel=category>New Juice</a></div><h3 class="title"><a
href=https://24hourhiphop.com/hip-hop-music/new-juice/t-black-ride-4-me-feat-nefia-son-official-music-video/ title="T Black &#8211; Ride 4 Me (Feat.Nefia Son) (Official Music Video) | 24HourHipHop" rel=bookmark>T Black &#8211; Ride 4 Me (Feat.Nefia Son) (Official Music Video)</a></h3><div
class="post-meta header-font"></div><div
class="post-excerpt "><p>Director: Alexia G Shot it Producers: Ja Magni &amp; Zoerab Model IG: reallifeofdee Album Name: Not Afraid to Die Alone Record label: 8+92 Records Music links: https://music.apple.com/us/album/not-afraid-to-die-alone/1515818878 [instagram-feed id=&#8221;@tblackforever&#8221;]</p></div><div
class="post-box-footer clearfix">
<a
class=read-more href=https://24hourhiphop.com/hip-hop-music/new-juice/t-black-ride-4-me-feat-nefia-son-official-music-video/ title="T Black &#8211; Ride 4 Me (Feat.Nefia Son) (Official Music Video) | 24HourHipHop" rel=bookmark>
Read more <i
class=icon-entypo-right-open></i>
</a>
<a
class=comment-count href=https://24hourhiphop.com/hip-hop-music/new-juice/t-black-ride-4-me-feat-nefia-son-official-music-video/#comments title="T Black &#8211; Ride 4 Me (Feat.Nefia Son) (Official Music Video)" rel=bookmark>
<i
class=icon-entypo-comment></i> 0 Comments	</a></div></div></article><article
class="post-118389 post-box fly-in animated-content post-box-small-thumbnail clearfix"><div
class=post-thumbnail-wrapper>
<a
href=https://24hourhiphop.com/hip-hop-music/new-juice/jackboy-make-me-lose-it-official-video/ title="Jackboy &#8211; Make Me Lose It (Official Video) | 24HourHipHop" rel=bookmark>
<img
width=80 height=80 src=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-347-80x80.jpg class="attachment-vw_square_tiny size-vw_square_tiny wp-post-image" alt srcset="https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-347-80x80.jpg 80w, https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-347-150x150.jpg 150w, https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-347-360x360.jpg 360w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id=118390 data-permalink=https://24hourhiphop.com/hip-hop-music/new-juice/jackboy-make-me-lose-it-official-video/attachment/maxresdefault-347-18/ data-orig-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-347.jpg data-orig-size=1140,641 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;} data-image-title=maxresdefault-347 data-image-description data-medium-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-347-300x169.jpg data-large-file=https://24hourhiphop.com/wp-content/uploads/2020/09/maxresdefault-347-1024x576.jpg>		</a></div><h3 class="title title-small"><a
href=https://24hourhiphop.com/hip-hop-music/new-juice/jackboy-make-me-lose-it-official-video/ title="Jackboy &#8211; Make Me Lose It (Official Video) | 24HourHipHop" rel=bookmark>Jackboy &#8211; Make Me Lose It (Official Video)</a></h3><div
class="post-categories clearfix"><div
class="label label-light label-small" title="Video Post"><i
class=icon-entypo-play></i></div><a
class="label label-small" href=https://24hourhiphop.com/category/hip-hop-music/new-juice/ title="View all posts in New Juice" rel=category>New Juice</a></div></article><article
class="post-117198 post-box fly-in animated-content post-box-small-thumbnail clearfix"><div
class=post-thumbnail-wrapper>
<a
href=https://24hourhiphop.com/hip-hop-music/new-juice/ziggy2sides-7-62-freestyle-feat-5hunnit-savage/ title="Ziggy2Sides- 7.62 freestyle (feat. 5hunnit Savage) | 24HourHipHop" rel=bookmark>
<img
width=80 height=80 src=https://24hourhiphop.com/wp-content/uploads/2020/08/hqdefault-1-80x80.jpg class="attachment-vw_square_tiny size-vw_square_tiny wp-post-image" alt srcset="https://24hourhiphop.com/wp-content/uploads/2020/08/hqdefault-1-80x80.jpg 80w, https://24hourhiphop.com/wp-content/uploads/2020/08/hqdefault-1-150x150.jpg 150w, https://24hourhiphop.com/wp-content/uploads/2020/08/hqdefault-1-360x360.jpg 360w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id=117199 data-permalink=https://24hourhiphop.com/hip-hop-music/new-juice/ziggy2sides-7-62-freestyle-feat-5hunnit-savage/attachment/hqdefault-1-61/ data-orig-file=https://24hourhiphop.com/wp-content/uploads/2020/08/hqdefault-1.jpg data-orig-size=480,360 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;} data-image-title=hqdefault-1 data-image-description data-medium-file=https://24hourhiphop.com/wp-content/uploads/2020/08/hqdefault-1-300x225.jpg data-large-file=https://24hourhiphop.com/wp-content/uploads/2020/08/hqdefault-1.jpg>		</a></div><h3 class="title title-small"><a
href=https://24hourhiphop.com/hip-hop-music/new-juice/ziggy2sides-7-62-freestyle-feat-5hunnit-savage/ title="Ziggy2Sides- 7.62 freestyle (feat. 5hunnit Savage) | 24HourHipHop" rel=bookmark>Ziggy2Sides- 7.62 freestyle (feat. 5hunnit Savage)</a></h3><div
class="post-categories clearfix"><div
class="label label-light label-small" title="Video Post"><i
class=icon-entypo-play></i></div><a
class="label label-small" href=https://24hourhiphop.com/category/hip-hop-music/new-juice/ title="View all posts in New Juice" rel=category>New Juice</a></div></article><article
class="post-117227 post-box fly-in animated-content post-box-small-thumbnail clearfix"><div
class=post-thumbnail-wrapper>
<a
href=https://24hourhiphop.com/hip-hop-music/new-juice/ksoo-back-to-back-official-music-video/ title="Ksoo &#8211; &#8220;Back to Back&#8221; (Official Music Video) | 24HourHipHop" rel=bookmark>
<img
width=80 height=80 src=https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-3-80x80.jpg class="attachment-vw_square_tiny size-vw_square_tiny wp-post-image" alt srcset="https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-3-80x80.jpg 80w, https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-3-150x150.jpg 150w, https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-3-360x360.jpg 360w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id=117228 data-permalink=https://24hourhiphop.com/hip-hop-music/new-juice/ksoo-back-to-back-official-music-video/attachment/hqdefault-3-34/ data-orig-file=https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-3.jpg data-orig-size=480,360 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;} data-image-title=hqdefault-3 data-image-description data-medium-file=https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-3-300x225.jpg data-large-file=https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-3.jpg>		</a></div><h3 class="title title-small"><a
href=https://24hourhiphop.com/hip-hop-music/new-juice/ksoo-back-to-back-official-music-video/ title="Ksoo &#8211; &#8220;Back to Back&#8221; (Official Music Video) | 24HourHipHop" rel=bookmark>Ksoo &#8211; &#8220;Back to Back&#8221; (Official Music Video)</a></h3><div
class="post-categories clearfix"><div
class="label label-light label-small" title="Video Post"><i
class=icon-entypo-play></i></div><a
class="label label-small" href=https://24hourhiphop.com/category/hip-hop-music/new-juice/ title="View all posts in New Juice" rel=category>New Juice</a></div></article><article
class="post-117196 post-box fly-in animated-content post-box-small-thumbnail clearfix"><div
class=post-thumbnail-wrapper>
<a
href=https://24hourhiphop.com/hip-hop-music/new-juice/rftb-official-music-video-rippa-hardaway-feat-natedagr8/ title="RFTB (Official Music Video) Rippa Hardaway  feat. NateDaGr8 | 24HourHipHop" rel=bookmark>
<img
width=80 height=80 src=https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-80x80.jpg class="attachment-vw_square_tiny size-vw_square_tiny wp-post-image" alt srcset="https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-80x80.jpg 80w, https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-150x150.jpg 150w, https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-360x360.jpg 360w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id=117197 data-permalink=https://24hourhiphop.com/hip-hop-music/new-juice/rftb-official-music-video-rippa-hardaway-feat-natedagr8/attachment/hqdefault-137/ data-orig-file=https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault.jpg data-orig-size=480,360 data-comments-opened=1 data-image-meta={&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;} data-image-title=hqdefault data-image-description data-medium-file=https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault-300x225.jpg data-large-file=https://24hourhiphop.com/wp-content/uploads/2020/09/hqdefault.jpg>		</a></div><h3 class="title title-small"><a
href=https://24hourhiphop.com/hip-hop-music/new-juice/rftb-official-music-video-rippa-hardaway-feat-natedagr8/ title="RFTB (Official Music Video) Rippa Hardaway  feat. NateDaGr8 | 24HourHipHop" rel=bookmark>RFTB (Official Music Video) Rippa Hardaway  feat. NateDaGr8</a></h3><div
class="post-categories clearfix"><div
class="label label-light label-small" title="Video Post"><i
class=icon-entypo-play></i></div><a
class="label label-small" href=https://24hourhiphop.com/category/hip-hop-music/new-juice/ title="View all posts in New Juice" rel=category>New Juice</a></div></article></div></div><div
id=text-8 class="widget vw-sidebar-blog widget_text"><div
class=textwidget>[instagram-feed]</div></div></div></aside></div></div><div
style=display:none></div> <script src="https://24hourhiphop.com/wp-content/cache/minify/69faf.js"></script>
 <script>var click_object = {"ajax_url":"https:\/\/24hourhiphop.com\/wp-admin\/admin-ajax.php"};</script> <script src="https://24hourhiphop.com/wp-content/cache/minify/4b2a4.js"></script>
 <script async=async src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=202040'></script>         <script src="https://24hourhiphop.com/wp-content/cache/minify/bdf7c.js"></script>
 <script async=async src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.1.1' async=async></script> <script src="https://24hourhiphop.com/wp-content/cache/minify/0bffa.js"></script>
 <script>var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "https://www.");
document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));</script> <script>try {
var pageTracker = _gat._getTracker("UA-2161503-1");
pageTracker._trackPageview();
} catch(err) {}</script> <script>;(function( $, window, document, undefined ){
				"use strict";

				$( document ).ready( function ($) {
							$( '.flexslider' ).flexslider({
			animation: "fade",
			easing: "easeInCirc",
			slideshow: true,
			slideshowSpeed: 4000,
			animationSpeed: 600,
			randomize: false,
			pauseOnHover: true,
			prevText: '',
			nextText: '',
			start: function( slider ) {
				slider.css( 'opacity', '1' );
				slider.find( '.post-thumbnail-wrapper' ).css( 'height', '500px' ).imgLiquid().fadeIn(250);
			},
		});
					} );
				
			})( jQuery, window , document );</script> <script src=https://stats.wp.com/e-202040.js async=async defer=defer></script> <script>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.7.1',blog:'84102659',post:'118505',tz:'-4',srv:'24hourhiphop.com'} ]);
	_stq.push([ 'clickTrackerInit', '84102659', '118505' ]);</script> </body></html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

Object Caching 191/226 objects using memcached
Page Caching using memcached 
Content Delivery Network via N/A
Minified using memcached
Database Caching 11/57 queries in 0.140 seconds using memcached (Request-wide modification query)
Application Monitoring using New Relic

Served from: 24hourhiphop.com @ 2020-09-30 01:45:31 by W3 Total Cache
-->